Стандартные программы Windows

Хорошо ли вы знаете Windows? Я думаю, что да. Знаете ли вы его на 100%? Вряд ли. Потому что программисты из Microsoft очень постарались, пряча некоторые функции и возможности от пользователей. Речь здесь пойдет о программах: самых обычных стандартных программах операционной системы, которые при установке ставятся по умолчанию и присутствие которых никак не афишируется. Более того, разработчики, как нарочно, пытаются отпугнуть пользователей от работы с этими утилитами. Посудите сами: программы нигде не упоминаются (ну, может быть в справке), на них нет ярлыков в меню "Пуск", а при попытке зайти в каталог Windows, где они, собственно, и находятся, появляется страшная надпись о том, что сюда заходить не надо, дабы не испортить системных файлов. Это может отпугнуть новичков. А ведь там немало полезных программ.


arp.exe

Местонахождение

Windows\system32

Описание

TCP/IP Arp Command

Команда Arp используется для просмотра, добавления или удаления записей в таблицах трансляции адресов IP в физические адреса. Эти записи используются при работе протокола Address Resolution Protocol (ARP)

Синтаксис

arp -a [inet_addr] [-N [if_addr]]
arp -d inet_addr [if_addr]
arp -s inet_addr ether_addr [if_addr]

Параметры

-a
Displays current ARP entries by querying TCP/IP. If inet_addr is specified, only the IP and physical addresses for the specified host are displayed.
-d
Deletes the entry specified by inet_addr.
-g
Same as -a
-s
Adds an entry in the ARP cache to associate the IP address inet_addr with the physical address ether_addr. The physical address is given as 6 hexadecimal bytes separated by hyphens. The IP address is specified using dotted decimal notation. The entry is static. It will not be automatically removed from the cache after the timeout expires and will not exist after a reboot of your computer.
-N [if_addr]
Displays the ARP entries for the network interface specified by if_addr.
ether_addr
Specifies a physical address.
if_addr
Specifies, if present, the IP address of the interface whose address translation table should be modified. If not present, the first applicable interface will be used.
inet_addr
Specifies an IP address in dotted decimal notation.


attrib.exe

Местонахождение

Windows\system32

Описание

Attribute Utility

Утилита командной строки позволяет просматривать, устанавливать или снимать атрибуты файла или каталога, такие как «Только чтение», «Архивный», «Системный» и «Скрытый». Выполненная без параметров команда attrib выводит атрибуты всех файлов в текущем каталоге.

Синтаксис

attrib [{+r|-r}] [{+a|-a}] [{+s|-s}] [{+h|-h}] [[диск:][путь] имя_файла] [/s[/d]]

Описание параметров есть в справке Windows


charmap.exe

Местонахождение

Windows\system32

Описание

Таблица символов - Character Map

Таблица символов служит для просмотра символов, включенных в выбранный шрифт. Она отображает следующие наборы символов: Windows, DOS и Юникод.

Отдельный символ или группу символов можно скопировать в буфер обмена, а затем вставить в любое приложение, в котором они будут отображаться. Многие программы, например WordPad, позволяют копировать символы путем их перетаскивания из таблицы символов непосредственно в открытый документ. Более подробное описание программы есть в справке


cleanmgr.exe

Местонахождение

WINDOWS\system32

Описание

Программа очистки дискового пространства для Windows - Disk Space Cleanup Manager for Windows

Программа очистки диска используется для освобождения пространства на жестком диске с помощью удаления временных файлов Интернета, установленных компонентов и программ, которые больше не используются, и очистки корзины. Программу можно запустить через Пуск-Все программы-Стандартные-Служебные-Очистка диска или через Пуск-Выполнить-cleanmgr


Cmd.EXE

Местонахождение

Windows\system32

Описание

Windows Command Processor

В Windows XP имеется так называемая консоль - программа Cmd.exe, которая является командным интерпретатором. При простом запуске, без указания параметров командной строки, консоль отображает версию операционной системы, информацию о защите авторских прав разработчиков ОС и саму командную строку, в которой можно ввести как параметр командной строки самой программы Cmd.exe, так и любую внешнюю команду, например, команду на запуск другого приложения или стандартную команду, типа mkdir, del и т. п.

Параметры командной строки

Синтаксис для командной строки:

CMD [/A | /U] [/Q] [/D] [/E:ON | /E:OFF] [/F:ON | /F:OFF] [/V:ON | /V:OFF]
[[/S] [/C | /K] команда]

Можно использовать одновременно несколько команд, используя между ними специальный разделитель - символы &&, при этом все сочетание нескольких команд должно быть заключено в кавычки, например, "команда&&команда&& команда".

/? - вызов справки
/A - вывод результатов выполнения заданной команды в формате ANSI
/C - выполнение заданной команды с последующим закрытием окна консоли
/D - отключение выполнения команд AutoRun (которые первыми автоматически выполняются при вызове cmd.exe), заданных в специальных разделах реестра HKEY_LOCAL_MACHINE\Software\Microsoft\Command Processor\AutoRun и HKEY_CURRENT_USER\Software\Microsoft\Command Processor\AutoRun
/E:ON (/E:OFF) - разрешение (запрет) расширений команд. В Windows XP по умолчанию включена расширенная обработка всех команд cmd.exe, этот параметр служит для включения / выключения расширений конкретного процесса. Расширенная обработка включает следующие команды: assoc, call, chdir (cd), color, del (erase), endlocal, for, ftype, goto, if, mkdir (md), popd, prompt, pushd, set, setlocal, shift, start (изменен также вызов внешних команд)
/F:ON (/F:OFF) - разрешение (запрет) завершения имен файлов и папок (по умолчанию выключено) конкретного вызова cmd.exe. Довольно удобная функция, позволяющая не вводить полностью вручную в окне консоли пути к файлам или имена самих папок, а ввести только часть длинного пути и с помощью нажатия специальной комбинации клавиш дать операционной системе найти подходящие варианты и просто выбрать нужный. (Если необходимо включить или отключить завершение имен для всех вызовов cmd.exe, то смотри Автонабор команд). Параметры пользователя имеют приоритет над параметрами компьютера, значение параметра /F командного процессора имеет приоритет над параметрами реестра. Microsoft вносит некоторые разъяснения по поводу использования этой функции: "Если завершение включено с помощью ключа командной строки / F:ON, то используются два управляющих символа: Ctrl+D для имен папок и Ctrl+F для имен файлов. Чтобы отключить конкретный символ завершения в системном реестре, в качестве кода специального символа используется шестнадцатеричное значение символа пробела (0 x 20). Завершение вызывается при вводе одного из этих двух специальных символов. Функция завершения берет строку пути слева от точки ввода, дописывает к ней символ шаблона, если таковой отсутствует, а затем строит список путей, которые соответствуют полученному определению. После этого выводится первый элемент этого списка соответствующих путей. Если же список пуст, то подается звуковой сигнал, и ничего не выводится. После этого повторный ввод того же самого специального символа приводит к циклическому перебору всех соответствующих путей. Нажатие клавиши Shift при вводе управляющего символа позволяет просматривать список путей в обратном порядке. Если изменить выведенный путь, а затем снова ввести управляющий символ, сохраненный список очищается, и строится новый список путей. То же самое происходит, если переключиться с одного символа завершения на другой. Единственное отли чие при использовании символа завершения файла состоит в том, что при этом для построения списка соответствия берется и путь, и имя файла, а при использовании символа завершения папки - только путь. Если символ завершения используется в одной из встроенных команд манипулирования папками (CD, MD или RD), то всегда подразумевается символ завершения папок. Символ завершения правильно работает и с именами файлов, содержащими пробелы или иные специальные символы, если при этом строка соответствия заключена в кавычки. Кроме того, если сместить точку ввода влево, а затем использовать символ завершения внутри строки, оставшийся справа от точки ввода текст будет отброшен. Специальные символы, которые требуют обязательного заключения в кавычки: <пробел>&()[]{}^=;!'+,~". Все понятно?
/K - выполнение заданной команды без последующего завершения (окно консоли не закроется)
/Q - отключение вывода команд на экран (ECHO OFF). /R - аналогичен параметру /C
/S - изменение поведения команды после /C или /K
/T:цвет - задание цвета текста и фона окна консоли. Параметр цвет имеет значение в виде двух шестнадцатеричных чисел: первое определяет цвет фона окна, а второе - текста в окне. То есть результатом выполнения команды "CMD /T:7С" будут светло-красные буквы на белом фоне.
/U - вывод результатов выполнения команды в формате Unicode
/V:ON (/V:OFF) - разрешение (запрет) отложенного расширения переменных среды (для конкретного вызова cmd.exe) с применением восклицательного знака "!" в качестве разделителя. Например, /V:ON разрешает использовать !var! в качестве расширения переменной var во время выполнения. Синтаксис var служит для расширения переменных при вводе, что приводит совсем к другим результатам внутри цикла FOR. При включенном отложенном расширении переменных среды символ "!" (восклицательный знак) может использоваться для замены текущего значения переменной среды во время выполнения; /X - означает то же, что и ключ /E:ON, из соображений совместимости; /Y то же, что и /E:OFF. И еще несколько замечаний. Если указаны ключи /C или /K, то остальная часть командной строки после такого ключа обрабатывается как командная строка, а обработка символов кавычек (") ведется таким образом. Символы кавычек в командной строке сохраняются, если выполняются все перечисленные ниже условия: ключ /S отсутствует; есть ровно два символа кавычек; между ними нет других специальных символов, как то: &<>()@^|; между ними имеются один или несколько пробелов; строка, заключенная в кавычки, является именем исполняемого файла. В противном случае проверяется первый символ, и если он является символом кавычек, то он удаляется, также удаляется последний символ кавычек в командной строке, а весь текст после этого последнего символа кавычек сохраняется.

Таблица для задания цвета текста и фона окна консоли
0 - черный | 1 - синий | 2 - зеленый | 3 - голубой
4 - красный | 5 - лиловый | 6 - желтый | 7 - белый
8 - серый | 9 - светло-синий | A - светло-зеленый | B - светло-голубой
C - светло-красный | D - светло-лиловый | E - светло-желтый | F - ярко-белый
Кстати, цвет и другие настройки можно изменять и другим способом. Щелкните правой кнопкой мыши по строке заголовка окна и выберите пункт Свойства. Откроется окно с четырьмя вкладками, на которых будут доступны опции изменения настроек программы. Если вам не нравится стандартный черный экран командной строки, то на вкладке Color вам предлагается выбрать цвет экрана и текста либо из 16 стандартных цветов, для которых имеется соответствующие образцы, либо задав числовое значение цвета в формате RGB. На вкладке Layout настраивается размер окна и экранного буфера. Если в ранних ОС MS-DOS и Windows размер экрана оставался неизменным 25 строк в высоту и 80 символов в длину, и для вывода большего количества строк приходилось добавлять команду |more, то в системах NT и более поздних можно просто задать достаточно большой размер буфера экрана и пользоваться полосой прокрутки, что гораздо удобнее. Текст в окне командной строки Для копирования и вставки текста в окно командной строки обычные для Windows комбинации клавиш, такие как Ctrl+C, Ctrl+V, работать не будут. Для извлечения текста из буфера обмена вам придется вызвать меню, щелкнув правой кнопкой мыши по заголовку окна, и выбрать подменю Edit. Или же просто щелкните правой кнопкой по окну. Для копирования текста из окна выберите пункт Mark и мышью выделите нужный текст. Затем либо нажмите Enter, либо в том же меню выберите Copy. Если надо вставить какой-то текст в окно командной строки, обратитесь к команде Paste. Для повторного выполнения команды воспользуйтесь стрелками <<вверх>> и <<вниз >>, позволяющими перемещаться по списку выполненных команд. Для очистки экрана от текста служит директива cls.

Команды

TITLE - для изменения заголовка строки
TITLE [строка], где строка - это будущий заголовок окна командной строки (записывается без кавычек). После задания заголовка окна он может быть изменен только повторным вызовом команды TITLE. Использование данной команды может быть полезно в командных файлах. Так, выполнение примера, который приведен ниже, будет сопровождаться появлением соответствующей надписи в заголовке окна:

@ECHO OFF
TITLE Копируются файлы...
COPY \\Server\Share\*.doc C:\User\Common\*.doc
ECHO Копирование закончено.
TITLE Процесс завершен

Команда АТ - С помощью этой команды можно запускать команды и программы в определенное время.
AT [\\имя компьютера] [ [id] [/DELETE] | /DELETE [/YES]]
AT [\\имя компьютера] time [/INTERACTIVE] [ /EVERY:дата[,...] | /NEXT:дата [,...]] "команда"
\\имя компьютера указывает на удаленный компьютер, на котором могут быть запущены планируемые задачи. Если этот параметр не указан, то по умолчанию предполагается тот компьютер, на котором запускается команда АТ;
id идентификатор, назначенный указанной команде;
/delete отменяет намеченную команду. Если id опущен, все назначенные команды на компьютере отменены;
/yes этот параметр в случае использования с предыдущим параметром (/delete) автоматически включает подтверждение для всех запросов;
time время выполнения команды (в 24-часовом формате часы:минуты);
/interactive позволяет команде AT обмениваться с подключенными на данный момент в системе пользователями;
/every:дата[,...] выполняет команду в каждый указанный день (дни) недели или месяц. Если дата опущена, подразумевается текущий день месяца;
/next:дата[...] выполняет указанную команду при следующем наступлении указанной даты (например, в следующий четверг). Если дата не указанна, по умолчанию принимается текущий день месяца;
"команда" указывается команда Windows NT или пакетная программа, которая будет выполнена. Имя файла должно указываться полностью. При этом, если выполняется какая-либо из внутренних команд, например, COPY или DIR, а не исполняемый файл, то необходим запуск командного интерпретатора с ключом / С, например: AT 10:00 "CMD /C DIR > C:\test.out.
Команда For - Ее возможности обширны, но мы ограничимся демонстрацией лишь одной из них - Копирование по сети на все машины сразу. Допустим, что требуется скопировать файл на двадцать машин. Делается это очень быстро. Сначала в файл list.txt записываем список всех имеющихся в сети машин. В консоли пишем:

net view > c:\list.txt
Затем, чтобы выполнить, например, копирование файла patch.exe на каждую машину из списка, даем команду:
FOR /F "tokens=1" %i in (с:\list.txt) do copy d:\temp\patch.exe "%i\C$\program files\ICQ"
Переменная %i будет автоматически принимать значение NetBIOS-имени машины из новой строки файла list.txt и на эту машину будет производиться копирование.

Реестр

Изменение вида приглашения командной строки


cscript.exe

Местонахождение

Windows\system32

Описание

Microsoft (r) Console Based Script Host

Сервер сценариев cscript.exe является консольным вариантом, предназначенный для взаимодействия с пользователем через командную строку (в отличии от GUI-приложения wscript.exe).

Синтаксис

cscript [имя_сценария] [параметры_сервера] [аргументы_сценария]

Описание параметров есть в справке Windows


defrag.exe

Местонахождение

Windows\system32

Описание

Disk Defragmenter Module

Поиск и объединение фрагментированных файлов загрузки, файлов данных и папок на локальных томах.

Синтаксис

defrag том

defrag том [/a]

defrag том [/a] [/v]

defrag том [/v]

defrag том [/f]

Описание параметров есть в справке Windows


diskpart.exe

Местонахождение

Windows\system32

Описание

Diskpart Application

Программа DiskPart.exe — это работающий в текстовом режиме командный интерпретатор, который позволяет управлять объектами (дисками, разделами или томами) с помощью сценариев или команд, вводимых с командной строки.

Синтаксис

diskpart [/add | /delete] [имя_устройства | имя_диска | имя_раздела] [размер]

Описание программы есть в справке Windows


drwtsn32.exe

drwtsn32.exe (Доктор Ватсон в Windows)

Местонахождение

Windows\system32

Описание

DrWatson Postmortem Debugger

Программа Доктор Ватсон (Drwtsn32.exe) устанавливается в системную папку при установке Windows. Параметры, используемые по умолчанию, задаются при первом запуске программы «Доктор Ватсон», который выполняется при возникновении программной ошибки или по команде пользователя.

При возникновении программной ошибки в Windows система выполняет поиск обработчика программных ошибок. Он обрабатывает ошибки по мере их возникновения во время выполнения программы. Если найти обработчик не удается, система проверяет, чтобы приложение не находилось в режиме отладки, после чего рассматривает ошибку как не подлежащую обработке. Далее система ищет отладчик программных ошибок в системном реестре и обрабатывает такие ошибки.

Более подробное описание программы ищите в справке Windows


explorer.exe

Местонахождение

Windows

Описание

Проводник - Windows Explorer

Одна из основных программ Windows для навигации по папкам и дискам

Ключи командной строки Проводника

  • /e - Вид Проводника по умолчанию (двухпанельное), иначе выводится как однопанельное (как Папка).
  • /e, object - Открывается Проводник с видом по умолчанию и с фокусом на заданной папке (Explorer /e,C:\Windows)
  • /n - Открытие однопанельного нового окна на диске, на котором установлена система (C:\). Иначе информация выводится в существующем окне Проводника, если оно открыто.
  • /root, object - Указывает на то, что корнем будет object - это дисковод (сетевой или локальный) или папка. Иначе корнем считается Рабочий стол. (Explorer /root, C:\Windows\Cursors)
  • /select, object - Указывает на необходимость открытия Родительской папки объекта object и выделит object (Explorer /select, C:\Windows\Cursors\banana.ani).

Советы

По умолчанию Проводник открывается на диске C:, но вы можете изменить это поведение...


fc.exe

Местонахождение

Windows\system32

Описание

DOS 5 File Compare Utility

Утилита командной строки для сравнения двух файлов и вывода различий между ними

Синтаксис

fc [/a] [/b] [/c] [/l] [/lbn] [/n] [/t] [/u] [/w] [/nnnn] [диск1:][путь1]имяфайла1 [диск2:][путь2]имяфайла2

Описание параметров есть в справке Windows

Советы

Есть простой способ отследить изменения, которые происходят в реестре Windows


find.exe

Местонахождение

Windows\system32

Описание

Find String (grep) Utility

Поиск заданной строки текста в файле или нескольких файлах. После поиска в заданных файлах команда find выведет на экран все строки из этих файлов, содержащие заданный образец.

Синтаксис

find [/v] [/c] [/n] [/i] "строка" [[диск:][путь]ИмяФайла[...]]

Описание параметров есть в справке Windows


fsutil.exe

Местонахождение

Windows\system32

Описание

fsutil.exe

Fsutil является служебной программой командной строки, которая используется для выполнения связанных задач файловых систем FAT и NTFS, таких как управление точками повторной обработки, управление разреженными файлами, отключение тома или расширение тома. Поскольку программа fsutil является весьма мощной, ее должны применять только опытные пользователи, имеющие опыт работы с Microsoft Windows XP. Для использования программы fsutil необходимо войти в систему с помощью учетной записи администратор или члена группы администраторов.

Описание программы и ее подкоманд есть в справке Windows.

Для отображения справки о подкомандах утилиты используйте команду

fsutil подкоманда help

Применение

С помощью утилиты командной строки fsutil можно создать файл с заданным размером. Например, вам надо создать файл sample.txt размером 1 кб, не заботясь о его содержании. Делаем так:

fsutil file createnew FileName Size
где FileName - имя файла (sample.txt, или c:\folder\sample.txt), а Size - размер файла в байтах.


ftp.exe

Местонахождение

Windows\system32

Описание

File Transfer Program

Позволяет передавать файлы с компьютера и на компьютер с помощью программ, поддерживающих протокол FTP (File Transfer Protocol)

Синтаксис

ftp [-v] [-d] [-i] [-n] [-g] [-s:имя_файла] [-a] [-w:размер] [-A] [Ведомый компьютер]

Описание параметров есть в справке Windows


hostname.exe

Местонахождение

Windows\system32

Описание

Hostname APP

Утилита командной строки hostname выводит имя системы, на котором была запущена эта команда

Синтаксис

hostname

У данной команды нет параметров


iexpress.exe

Местонахождение

Windows\system32

Описание

Wizzard

В Windows XP есть простейший инстяллятор файлов IExpress. Удобный диалог, упаковывает файлы в exe-файлы, один минус: не руссифицирован. Причем, например, 2 десятка картинок сжимаются даже лучше чем в WinRAR 3.0


ipconfig.exe

Местонахождение

Windows\system32

Описание

IP Configuration Utility

Утилита командной строки Ipconfig служит для отображения всех текущих параметров сети TCP/IP и обновления параметров DHCP и DNS. При вызове команды ipconfig без параметров выводится только IP-адрес, маска подсети и основной шлюз для каждого сетевого адаптера

Синтаксис

ipconfig [/all] [/renew [адаптер]] [/release [адаптер]] [/flushdns] [/displaydns] [/registerdns] [/showclassid адаптер] [/setclassid адаптер [код_класса]]

Описание параметров есть в справке Windows


lpq.exe

Местонахождение

Windows\system32

Описание

TCP/IP Lpq Command

Служит для отображения состояния очереди печати на компьютере, использующем программное обеспечение сервера печати Line Printer Daemon (LPD). При вызове команды lpq без параметров в командной строке отображается справка по этой команде

Синтаксис

lpq -S имя_сервера -P имя_принтера [-l]

Описание параметров есть в справке Windows


makecab.exe

Местонахождение

WINDOWS\system32

Описание

Microsoft® Cabinet Maker

Утилита командной строки makecab.exe служит для создания cab-файлов

Для получения списка параметров используйте ключ makecab /?


migwiz.exe

Местонахождение

WINDOWS\system32\usmt

Описание

Мастер переноса файлов и параметров - Files and Settings Transfer Wizard

Очень удобная утилита для переноса файлов и параметров различных программ с одного компьютера на другой. Например, вы легко перенесете все настройки и письма из Outlook Express. Программу можно запустить через Пуск-Все программы-Стандартные-Служебные-Мастер переноса файлов и параметров или через Пуск-Выполнить-migwiz


mmc.exe

Местонахождение

Windows\system32

Описание

Консоль управления (MMC) - Microsoft Management Console

Консоль MMC (Microsoft Management Console) группирует средства администрирования, которые используются для администрирования компьютеров, служб, других системных компонентов и сетей. Впервые она появилась в Windows 2000. Чтобы запустить ее, проделайте следующее:
Пуск->Выполнить->mmc. Перед вами откроется окно.

Дальше необходимо добавить групповую политику "Локальный компьютер", где и будут проводиться все настройки. Для этого выберите пункт меню Консоль->Добавить или удалить оснастку..., в появившемся окне нажмите кнопку "Добавить", и из появившегося диалога "Добавить изолированную оснастку" выберите "Групповая политика". Нажмите последовательно кнопки "Готово", "Закрыть", "ОК".

Давайте попробуем убрать пункт "Выполнить" из меню "Пуск" с помощью этого инструмента. В левой части окна консоли перед вами древовидная структура настраиваемых параметров операционной системы. Откройте пункт меню Конфигурация пользователя->Административные шаблоны->Панель задач и меню "Пуск". В расширенном варианте отображения данных вы сможете почитать описание настраиваемого пункта. Если вы знаете что именно вам надо настроить, то лучше переключиться в стандартный режим, чтобы не занимать лишнее место на экране монитора ненужной вам информацией. Итак, найдите строку Удалить команду "Выполнить" из меню "Пуск".

Дважды кликните по ней левой кнопкой мыши, отметьте пункт "Включен" и нажмите "ОК". Теперь если вы выберите Пуск->Выполнить, то увидите сообщение, что операция отменена вследствие действующих для компьютера ограничений. После перезагрузки этот пункт вообще пропадет из меню "Пуск". Аналогичным образом можно настроить и другие параметры меню "Пуск" и не только. Значения "Включен" и "Отключен" показывают действует или нет данная политика, а значение "Не задан" возвращает настройку политики в значение по умолчанию, заложенное в операционной системе. Вы наверняка уже обратили внимание на большое количество параметров, которые можно настроить с помощью оснастки MMC. Действительно, здесь можно настроить очень многие параметры операционной системы без использования дополнительных инструментальных средств. Описывать их все нет смысла, так что если вас заинтересовал этот способ твикинга, ознакомьтесь с ними самостоятельно, тем более описание настраиваемых параметров дает более чем исчерпывающую информацию. Ну, а для начального знакомства с оснасткой MMC приведенных сведений должно хватить.

Оснастки

  • Локальные пользователи и группы - Local Users and Groups
  • Управление дисками - Disk Management

Реестр

Запрет на запуск консоли управления в авторском режиме


msconfig.exe

msconfig.exe (Настройка системы)

Местонахождение

WINDOWS\PCHealth\HelpCtr\Binaries

Описание

System Configuration Utility

После загрузки появляется окно с шестью вкладками:
- Общие - позволяет управлять параметрами запуска системы.
- Config.sys - редактирование файла config.sys.
- Autoexec.bat - соответственно.
- System.ini.
- Win.ini.
- Автозагрузка - здесь перечислены все программы, которые запускаются при загрузке системы.
Очень удобно то, что все собрано в одном месте. Не надо лазить по реестру и файлам, чтобы посмотреть, что загружается на компьютере. Можно отключить загрузку любой программы или выполнение строки одного из перечисленных файлов, не правя ничего вручную. При этом комментарии будут расставлены автоматически, а программы, запускаемые из реестра, например, из раздела "Run", будут перенесены в раздел "Run-" (в конце соответствующего раздела добавляется символ "-").

Более подробное описание программы есть в справке самой программы

Реестр

Удаление ненужных записей


msinfo32.exe

msinfo32.exe (Сведения о системе)

Местонахождение

C:\Program Files\Common Files\Microsoft Shared\MSInfo

Описание

System Information

Программа Сведения о системе собирает и отображает данные о конфигурации системы как для локальных, так и для удаленных компьютеров. Сюда входит информация о конфигурации оборудования, компонентах компьютера, а также программном обеспечении, в том числе о подписанных и неподписанных драйверах. При устранении неполадок, связанных с конфигурацией системы, сотрудникам службы технической поддержки необходимы определенные данные о компьютере. Программа «Сведения о системе» позволяет быстро собрать необходимые данные.

Для хранения данных о системе предназначены файлы с расширением .nfo. Кроме того, программа «Сведения о системе» работает с файлами форматов .cab и .xml. Содержимое открытого файла .cab можно просматривать средствами меню Сервис.

Синтаксис

msinfo32 [/?] [/pch] [/nfo имя_файла] [/report имя_файла] [/computer имя_компьютера] [/showcategories] [/category код_категории] [/categories код_категории]

Описание программы есть в справке Windows


mspaint.exe

Местонахождение

Windows\system32

Описание

Paint

Оказывается, в Microsoft Paint можно быстро увеличить картинку аж в 10 раз. Для этого активизируйте инструмент Лупа. В нижней части поля, где фиксируется степень увеличения, находится тонкая белая линия. Аккуратно щелкните по ней. Как себя чувствует ваша картинка?

Если при работе в Paint, во время рисования линии удерживать нажатой клавишу Shift, то будет рисоваться прямая линия. Если проводить линию под углом, то при этом угол будет составлять 45 градусов.

А если удерживать нажатой клавишу Shift при рисовании фигур, то будет рисоваться квадраты и круги, вместо прямоугольников и эллипсов.


netstat.exe

Местонахождение

Windows\system32

Описание

TCP/IP Netstat Command

Отображение активных подключений TCP, портов, прослушиваемых компьютером, статистики Ethernet, таблицы маршрутизации IP, статистики IPv4 (для протоколов IP, ICMP, TCP и UDP) и IPv6 (для протоколов IPv6, ICMPv6, TCP через IPv6 и UDP через IPv6). Запущенная без параметров, команда nbtstat отображает подключения TCP.

Синтаксис

netstat [-a] [-e] [-n] [-o] [-p протокол] [-r] [-s] [интервал]

Описание программы есть в справке Windows

Чтобы вывести все активные подключения, отсортированные по возрастанию номера порта, необходимо набрать:

netstat -n


notepad.exe

Местонахождение

Windows\system32

Описание

Notepad

Простейший текстовый редактор, известный как Блокнот. Используется для создания и просмотра простых текстовых документов. Многие веб-дизайнеры используют Блокнот в качестве инструмента для создания интернет-страничек, не доверяя более навороченным программам! В каждой новой версии Windows приобретал новые возможности. В Windows XP текстовый редактор уже научился понимать некоторые кодировки. В Windows традиционно используется в качестве просмотра HTML-кода, log-файлов и т.п.

Советы

Блокнот для ежедневных заметок

Реестр

Настройка шрифтов


nslookup.exe

Местонахождение

Windows\system32

Описание

nslookup APP

Предоставляет сведения, предназначенные для диагностики инфраструктуры DNS. Для использования этого средства необходимо быть знакомым с принципами работы системы DNS. Средство командной строки Nslookup доступно, только если установлен протокол TCP/IP

Синтаксис

nslookup [-подкоманда ...] [{искомый_компьютер| [-сервер]}]

Описание параметров есть в справке Windows


openfiles.exe

Местонахождение

Windows\system32

Описание

Open Files

Запрашивает или отображает открытые файлы. Также запрашивает, отображает или разъединяет файлы, открытые сетевыми пользователями.

Синтаксис

openfiles.exe /query [/s компьютер [/u домен\пользователь [/p пароль]]] [/fo {TABLE|LIST|CSV}] [/nh] [/v]

Описание параметров есть в справке Windows


pathping.exe

Местонахождение

Windows\system32

Описание

TCP/IP PathPing Command

Утилита командной строки pathping.exe в течение некоторого периода времени отправляет многочисленные сообщения с эхо-запросом каждому маршрутизатору, находящемуся между исходным пунктом и пунктом назначения, а затем на основании пакетов, полученных от каждого из них, вычисляет результаты. Поскольку pathping показывает коэффициент потери пакетов для каждого маршрутизатора или связи, можно определить маршрутизаторы или субсети, имеющие проблемы с сетью. Команда Pathping выполняет эквивалентное команде tracert действие, идентифицируя маршрутизаторы, находящиеся на пути. Затем она периодически в течение заданного времени обменивается пакетами со всеми маршрутизаторами и на основании числа пакетов, полученных от каждого из них, обрабатывает статистику. Запущенная без параметров, команда pathping выводит справку.

Описание программы и ее подкоманд есть в справке Windows.

Для отображения справки о подкомандах утилиты используйте команду pathping без параметров в командной строке

pathping

Синтаксис

pathping [-n] [-h максимальное_число_переходов] [-g список_узлов] [-p период] [-q число_запросов [-w интервал] [-T] [-R] [имя_конечного_компьютера]

Параметры

-n
Предотвращает попытки команды pathping сопоставить IP-адреса промежуточных маршутизаторов с их именами. Это позволяет ускорить вывод результатов команды pathping.
-h максимальное_число_переходов
Задает максимальное количество переходов на пути при поиске конечного пункта назначения. Значение по умолчанию равно 30.
-g список_узлов
Указывает для сообщений с эхо-запросом использование параметра свободной маршрутизации в IP-заголовке с набором промежуточных мест назначения, указанным в списке_компьютеров. При свободной маршрутизации последовательные промежуточные места назначения могут быть разделены одним или несколькими маршрутизаторами. Максимальное число адресов или имен в списке равно 9. Список_адресов представляет собой набор IP-адресов (в точечно-десятичной нотации), разделенных пробелами.
-p период
Задает время ожидания между последовательными проверками связи (в миллисекундах). Значение по умолчанию равно 250 миллисекунд.
-q число_запросов
Задает количество сообщений с эхо-запросом, отправленных каждому маршрутизатору пути. По умолчанию - 100.
-w интервал
Задает время ожидания каждого отклика (в миллисекундах). Значение по умолчанию равно 3000 миллисекунд.
-T
Присоединяет тег приоритета уровня 2 (например 802.1p) к сообщениям с эхо-запросом, отправляемым каждому сетевому устройству на маршруте. Это помогает обнаружить сетевые устройства, для которых не настроен приоритет уровня 2. Он предназначен для проверки соединений, использующих спецификации QoS.
-R
Проверяет, все ли сетевые устройства вдоль маршрута поддерживают протокол RSVP (Resource Reservation Setup Protocol, протокол настройки резервирования ресурсов), который позволяет главному компьютеру резервировать определенную часть пропускной способности для потока данных. Этот параметр предназначен для проверки соединений, использующих спецификации QoS.
имя_конечного_компьютера
Задает пунтк назначения, идентифицированный IP-адресом или именем узла.
/?
Отображает справку в командной строке.

Примечания

Параметры команды Pathping вводятся с учетом регистра.

Во избежание перегрузки сети пакеты должны передаваться через довольно большие интервалы времени.

Чтобы минимизировать эффект потери пакетов, не нужно слишком часто выполнять проверку связи.

После запуска pathping сначала выводится путь. Это тот же путь, который выводится командой tracert. Далее в течение 90 секунд команда выдает сообщение о том, что она занята (это время варьируется в зависимости от числа переходов).В течение этого времени происходит сбор сведений со всех маршрутизаторов, перечисленных выше, и со всех соединений между ними. По завершении этого периода выводятся результаты проверки.


ping.exe

Местонахождение

Windows\system32

Описание

TCP/IP Ping Command

Утилита командной строки Ping проверяет соединение на уровне протокола IP с другим компьютером, поддерживающим TCP/IP, с помощью отправки сообщений с эхо-запросом по протоколу ICMP . После каждой передачи выводится соответствующее сообщение с эхо-ответом. Ping - это основная TCP/IP-команда, используемая для устранения неполадки в соединении, проверки возможности доступа и разрешения имен. Команда ping, запущенная без параметров, выводит справку.

Синтаксис

ping [-t] [-a] [-n счетчик] [-l размер] [-f] [-i TTL] [-v тип] [-r счетчик] [-s счетчик] [{-j список_узлов | -k список_узлов}] [-w интервал] [имя_конечного_компьютера]

Описание параметров есть в справке Windows

Команда Ping лежит в основе диагностики сетей TCP/IP. Например, чтобы быстро получить значения параметров конфигурации TCP/IP на своем компьютере, следует набрать:

C:\>ping 127.0.0.1


progman.exe

Местонахождение

Windows\system32

Описание

Program Manager (Диспетчер программ)

Из Windows 3.1 нам достался такой замечательный продукт, как PROGMAN.EXE. Он представляет из себя панель, которая с успехом может заменить Рабочий Стол, поскольку позволяет завести внутри себя неограниченное количество Групп, каждая из которых может содержать произвольное количество ярлыков (команды "Создать группу" и "Создать элемент" соответственно). Ярлык PROGMAN.EXE имеет смысл или помещать в стартовую папку с параметром "Свёрнутое в значок" (Windows 95, NT), или выводить на панель Quick Launch.
В результате можно существенно разгрузить Рабочий Стол, оставив на нём только необходимое. Остальные рабочие ярлыки можно разместить по группам Прогмана. В результате получится что-то вроде свёртываемого Рабочего Стола с рядом Рабочих Подстолов внутри!
P.S. К сожалению, PROGMAN.EXE обладает одним "родимым пятном" Windows 3.1: он не понимает длинных имён файлов, которые надо преобразовывать в короткие. Однако это неудобство не сильно умаляет его достоинства.


route.exe

Местонахождение

Windows\system32

Описание

TCP/IP Route Command

Эта команда нужна для редактирования или просмотра таблицы маршрутов IP из командной строки. Ключ /? выводит все доступные ключи при работе с Route.

Синтаксис


rundll32.exe

Местонахождение

Windows\system32

Описание

Run a DLL as an App

Windows имеет в своем составе утилиту командной строки rundll32.exe, которая позволяет запускать некоторые команды-функции, заложенные в DLL-файлах.

Вообще-то данная утилита была разработана для внутреннего пользования программистами Microsoft. Но богатые возможности этой программы дало повод на всеобщее использование пользователями.

Область применения данной утилиты довольно широк. Вы можете вводить приведенные ниже команды в окне Запуск программы (Пуск-Выполнить), также создать ярлыки с заданнами параметрами запуска, использовать в коде на программируемом вами языке (C++, Delphi, Visual Basic и т.д.)

Список команд слишком обширен. Приведем список наиболее значимых команд.

  • rundll32 shell32.dll,Control_RunDLL hotplug.dll - диалоговое окно Отключение или извлечение аппаратного устройства
  • rundll32 diskcopy,DiskCopyRunDll - вызов диалога "Копирование диска".
  • rundll32 keyboard,disable - отключение клавиатуры, действует до следующей перезагрузки.
  • rundll32 mouse,disable - отключение мыши вплоть до перезагрузки.
  • rundll32 krnl386.exe,exitkernel - выгрузить ядро системы, выход из Windows.
  • rundll32 mshtml.dll,PrintHTML "HtmlFileNameAndPath" - распечатать документ HTML, где "HtmlFileNameAndPath" - путь к файлу и его имя.
  • rundll32 мсprint2.dll,RUNDLL_PrintTestPage - распечатать тестовую страницу на принтере.
  • rundll32 netplwiz.dll,AddNetPlaceRunDll - вызов мастера подключения нового сетевого ресурса "Добавление в сетевое окружение".
  • rundll32 rnaui.dll,RnaWizard - вызов мастера "Удаленный доступ к сети".
  • rundll32 rnaui.dll,RnaWizard /1 - вызов мастера "Удаленный доступ к сети" без отображения начального окна.
  • rundll32 shell,ShellExecute - открыть Проводник (папка "Рабочий стол").
  • rundll32 shell32,Control_RunDLL - открыть в Проводнике папку "Панель управления".
  • rundll32 shell32,Control_RunDLL appwiz.cpl,,n - вызов диалогового окна "Установка и удаление программ", в котором будет открыта вкладка с номером "n" (от 1 до 3).
  • rundll32 shell32,Control_RunDLL main.cpl @0 - открыть диалог "Свойства мыши".
  • rundll32 shell32,Control_RunDLL main.cpl @1 - открыть диалог "Свойства клавиатуры".
  • rundll32 shell32,Control_RunDLL main.cpl @2 - открыть папку "Принтеры".
  • rundll32 SHELL32,SHHelpShortcuts_RunDLL PrintersFolder - открыть папку "Принтеры" (другой способ).
  • rundll32 shell32,Control_RunDLL main.cpl @3 - открыть папку "Шрифты".
  • rundll32 SHELL32,SHHelpShortcuts_RunDLL FontsFolder - открыть папку "Шрифты" (другой способ).
  • rundll32 SHELL32,Control_RunDLL modem.cpl, add - открыть диалог "Свойства модема".
  • rundll32 shell32,Control_RunDLL timedate.cpl - открыть диалог "Дата и время".
  • rundll32 shell32,OpenAs_RunDLL - вызвать диалог "Открыть с помощью...".
  • rundll32 shell32,ShellAboutA WINHOWTO.RU - информация о версии Windows.
  • rundll32 shell32,SHExitWindowsEx 0 - закрыть все программы, перегрузить оболочку.
  • rundll32 shell32, SHExitWindowsEx 1 - выключить ПК.
  • rundll32 SHELL32, SHExitWindowsEx -1 - перегрузить оболочку Windows.
  • rundll32 shell32, SHExitWindowsEx 2 - перегрузить ПК.
  • rundll32 shell32,SHExitWindowsEx 4 - принудительно закрыть все программы.
  • rundll32 shell32,SHExitWindowsEx 8 - выход из Windows и выключение ATX-совместимого ПК.
  • rundll32 shell32,SHFormatDrive - вызов диалога форматирования диска А:.
  • rundll32 SHELL32,SHHelpShortcuts_RunDLL AddPrinter - запуск "Мастера установки принтера".
  • rundll32 shell32,SHHelpShortcuts_RunDLL Connect - запуск мастера подключения сетевого диска.
  • rundll32 SHELL32,SHHelpShortcuts_RunDLL PrintTestPage - распечатать тестовую страницу.
  • rundll32 sysdm.cpl,InstallDevice_Rundll - вызов мастера установки оборудования.
  • rundll32 url.dll,FileProtocolHandler %1 - открыть веб-страницу, где %1 - URL сайта (включая http://).
  • rundll32 url.dll,MailToProtocolHandler %1 - создать новое письмо, где %1 - e-mail адресата.
  • rundll32 user,CASCADECHILDWINDOWS - расположить все окна каскадом.
  • rundll32 user,TILECHILDWINDOWS - расположить все окна по экрану.
  • rundll32 user,disableoemlayer - сбой системы (!) - выключить все функции ввода-вывода (клавиатура, дисплей, мышь). В результате будет черный экран с курсором и ни на что не реагирующая система, однако Windows продолжает работать.
  • rundll32 user,ExitWindowsExec - быстрая перезагрузка Windows.
  • rundll32 user,RepaintScreen - выполнить команду "Обновить".
  • rundll32 user,SetCaretBlinkTime n - задать частоту мигания курсора, соответствующую значению параметра n.
  • rundll32 user,SetCursorPos - переместить курсор мыши в верхний левый угол экрана.
  • rundll32 user,SetDoubleClickTime n - задать скорость двойного нажатия левой кнопки мыши (Double Click), соответствующую параметру n.
  • rundll32 user,SwapMouseButton - поменять местами клавиши мыши (обратная смена невозможна).
  • rundll32 user,WNetConnectDialog - вызов диалога "Подключение сетевого диска".
  • rundll32 user,WNetDisconnectDialog - вызов диалога "Отключение сетевого диска".
  • rundll32 AppWiz.Cpl,NewLinkHere %1 - запуск мастера создания нового ярлыка, где %1 - путь к исходному файлу.


SFC.EXE

Местонахождение

Windows\system32

Описание

Windows 2000 System File Checker

Утилита SFC.EXE предназначена для проверки всех версий защищенных системных файлов и восстановления их из специального кэша в случае подмены или повреждения.

В Windows XP она запускается только из командной строки - в отличие от Windows 9х, где подобная утилита имеет графический интерфейс. Запуск утилиты возможен только с правами администратора, синтаксис такой:
sfc [/scannow] [/scanonce] [/scanboot] [/revert] [/cancel] [/enable] [/purgecache] [/cache size=x] [/quiet]

Параметры командной строки, которые можно задавать для программы SFC, следующие:

  • /scannow - немедленная проверка всех защищенных системных файлов
  • /scanonce - проверка защищенных системный файлов при следующей загрузке системы
  • /scanboot - проверка всех защищенных системных файлов при каждой загрузке системы
  • /revert - восстанавливает все настройки по умолчанию (Windows XP)
  • /cancel - отменяет все проверки защищенных системных файлов (Windows Me/2000)
  • /purgecache - очистка кэша защищенных файлов программы и немедленная проверка всех защищенных системных файлов
  • /cachesize=x - установка размера кэша защищенных файлов в мегабайтах (по умолчанию 50 мГб)
  • /enable - включение защиты системных файлов Windows (Windows Me/2000)
  • /quiet - замена поврежденных файлов без предупреждения (Windows Me/2000)
  • /? - вызов справки

Давайте рассмотрим практическое применение утилиты.

Папка dllcache

Если вас не устраивает, что Windows XP занимает слишком много места и восстанавливает удалённые из его директории файлы, то может удалить папку dllcache, но после следующей проверки системных файлов Windows снова заполнит эту папку. Для устранения этого "греха", после удаления или до удаления файлов (но не папки), нужно запустить команду sfc /cachesize=число. Числом будет количество мегабайт которое должно резервироваться для папки windows\system32\dllcache. Можно поставить = 0.

Поврежденные файлы

Предположим, вы обнаружили, что на вашем компьютере отсутствуют некоторые файлы, например, шрифты (шрифты - тоже системные файлы). Проверяем наличие системных файлов с помощью команды
sfc.exe /scannow
Windows проверит файлы и при необходимости переустановит недостающие или поврежденные.


Shutdown

SHUTDOWN.EXE

Местонахождение

Windows\system32

Описание

Windows Remote Shutdown Tool

Утилита Shutdown позволяет выключать или перегружать локальный или удаленный ПК, используя командную строку или специально созданный ярлык. Простой ее вызов без каких-либо параметров обеспечивает завершение сеанса текущего пользователя. Для использования всех возможностей этой утилиты необходимо задействовать параметры командной строки, синтаксис которых таков:
shutdown [{-l|-s|-r|-a}] [-f] [-m [\\Computer Name]] [-t xx] [-c "message"] [-d[u] [p]:xx:yy]

Подробнее о параметрах.
-l - завершение сеанса текущего пользователя. При наличии параметра -m последний имеет приоритет, то есть завершение сеанса производится для удаленного ПК
-s - выключить локальный ПК
-r - перезагрузка
-a - отмена выключения ПК, игнорируются все параметры, кроме -l и ComputerName. Данный параметр может использоваться только в тот момент, когда длится так называемый период тайм-аута, то есть когда программа Shutdown выделяет пользователю время на отмену своих действий
-f - разрешить принудительное закрытие всех работающих приложений
-m [\\ComputerName]- задать удаленный компьютер, который необходимо выключить
-t xx - задает временную задержку до вызова процедуры выключения компьютера в секундах - xx. По умолчанию используются 20 секунд
-c "message" - эта команда позволяет задать любое сообщение, которое будет отображаться в окне программы Shutdown. Максимальная длина сообщения - 127 символов. Текст сообщения необходимо заключать в кавычки
-d [u][p]:xx:yy - активирует некий специальный код выключения:
u - отображение пользовательского кода, p - отображение запланированного кода, xx - задает основной код (0-255), yy - задает дополнительный код (0-65536)
/? - отображает справочную информацию по программе


systeminfo.exe

Местонахождение

Windows\system32

Описание

System Information

Выводит на экран подробные сведения о конфигурации компьютера и операционной системы, сведения о безопасности, код продукта и параметры оборудования, такие как ОЗУ, дисковое пространство и сетевые карты

Синтаксис

systeminfo[.exe] [/s компьютер [/u домен\пользователь [/p пароль]]] [/fo {TABLE|LIST|CSV}] [/nh]

Описание параметров есть в справке Windows


taskkill.exe

Местонахождение

Windows\system32

Описание

Kill Process

Завершает одно или несколько заданий или процессов. Процессы могут быть уничтожены кодом процесса или именем образа.

Синтаксис

taskkill [/s компьютер] [/u домен\пользователь [/p пароль]]] [/fi имя_фильтра] [/pid код_процесса]|[/im имя_образа] [/f][/t]

Описание параметров есть в справке Windows


tasklist.exe

Местонахождение

Windows\system32

Описание

Task List

Отображает список приложений и служб с кодом процесса (PID) для всех задач, выполняющихся на локальном или удаленном компьютере.

Синтаксис

tasklist[.exe] [/s компьютер] [/u домен\пользователь [/p пароль]] [/fo {TABLE|LIST|CSV}] [/nh] [/fi фильтр [/fi фильтр2 [ ... ]]] [/m [модуль] | /svc | /v]

Описание параметров есть в справке Windows


taskmgr.exe

Местонахождение

Windows\system32

Описание

Windows TaskManager (Диспетчер задач Windows)

Описание программы есть в справке Windows.

Советы

Запустить программу можно как по имени файла taskmgr.exe, так и одновременным нажатием трех клавиш (Ctrl+Alt+Del).

Откройте Диспетчер задач, дважды шелкните левой кнопкой мыши по серой области окна чуть ниже меню и она развернется на все окно. Чтобы вернуть все назад, кликните еще два раза по бортику окна.


tracert.exe

Местонахождение

Windows\system32

Описание

TCP/IP Traceroute Command

Определяет путь до точки назначения с помощью посылки в точку назначения эхо-сообщений протокола Control Message Protocol (ICMP) с постоянным увеличением значений срока жизни (Time to Live, TTL). Выведенный путь — это список ближайших интерфейсов маршрутизаторов, находящихся на пути между узлом источника и точкой назначения. Ближний интерфейс представляют собой интерфейс маршрутизатора, который является ближайшим к узлу отправителя на пути. Например, чтобы вывести трассу маршрута к http://www.microsoft.com, нужно набрать:

C:\>tracert www.microsoft.com
Запущенная без параметров, команда tracert выводит справку

Синтаксис

tracert [-d] [-h максимальное_число_переходов] [-j список_узлов] [-w интервал] [имя_конечного_компьютера]

Описание параметров есть в справке Windows


wscript.exe

Местонахождение

Windows\system32

Описание

Microsoft (r) Windows Based Script Host

Сервер сценариев wscript.exe является GUI-вариантом, предназначенный для взаимодействия с пользователем через диалоговые окна Windows (в отличии от консольного приложения cscript.exe). С помощью сервера сценариев можно изменять реестр без вывода диалоговых окон, удалять и создавать файлы, многое другое.

Уникальная возможность - можно удалить файл скрипта до завершения его работы. То есть, скрипт сидит в памяти, а самого файла уже давно нет. Используя эту возможность можно создать так называемый скрипт-призрак.

Чтобы запустить написанный скрипт, можно просто дважды щелкнуть левой кнопкой мыши по нему в окне проводника. При этом сценарий запустится с настройками по умолчанию. Чтобы сценарий работал с другими параметрами, нужно в командной строке указать имя сервера сценариев, имя самого сценария и параметры запуска.

Синтаксис

wscript имя_сценария.расширение [параметры...] [аргументы...]
Чтобы получить полный список параметров, используйте wscript /?

Однако, такой вариант запуска изменит параметры по умолчанию для всех запускаемых впоследствии сценариев. Если в этом нет необходимости, есть возможность задать свои параметры для каждого отдельного файла сценария, более того, можно задать несколько вариантов запуска одного и того же сценария. Для этих целей служит файл с расширением wsh. Он представляет собой обычный текстовый файл и по своей структуре очень похож на inf или ini файл. Чтобы создать простейший *.wsh файл откройте свойства любого скрипта и на вкладке "Сценарий" измените любой параметр. После нажатия на "OK" в том же каталоге появится файл с аналогичным именем и расширением wsh. Вот пример одного из таких файлов:

[ScriptFile]
Path=G:\files\p010.js
[Options]
Timeout=0
DisplayLogo=1

В секции [ScriptFile] есть только один параметр - Path, который указывает на запускаемый скрипт, в секции [Options] перечисляются параметры для запуска этого скрипта.

Если теперь запустить созданный нами файл, он будет выполняться с настроенными параметрами.

Возможность указания параметров при старте сценариев является, безусловно, очень полезной и позволяет более тонко контролировать процесс работы скрипта


boot.ini

Местонахождение

C:\ (в корневой папке системного диска)

Описание

Файл boot.ini имеет очень много настроек. Microsoft посвятила описанию настроек в данном файле целую страницу на своем сайте. Оставляю описание почти без изменений. Если есть желание, то можете присылать переводы

Available switch options for the Windows XP and the Windows Server 2003 Boot.ini files

You can add many different switches to the Boot.ini file that will modify the way that Microsoft Windows XP or Microsoft Windows Server 2003 start.

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

102873 Boot.ini and ARC path naming conventions and usage

MORE INFORMATION

You can add the following switches to the Boot.ini file.

Note These switches apply to Microsoft Windows XP and to Microsoft Windows Server 2003, unless otherwise specified.

/basevideo

The /basevideo switch forces the system into standard 640x480 16-color VGA mode by using a video driver that is compatible with any video adapter. This switch permits the system to load if you selected the wrong video resolution or refresh rate. Use this switch in conjunction with the /sos switch. If you install a new video driver, and it does not work correctly, you can use this parameter to start the operating system. You can then remove, update, or roll back the problem video driver.

/baudrate=number

This switch sets the baud rate of the debug port that is used for kernel debugging. For example, type /baudrate=9600. The default baud rate is 9600 kilobits per second (Kbps) if a modem is attached. The default baud rate is 115,200 Kbps for a null-modem cable. 9,600 is the normal rate for remote debugging over a modem. If this switch is in the Boot.ini file, the /debug switch is automatically enabled.

For additional information about modem configuration, click the following article number to view the article in the Microsoft Knowledge Base:

148954 How to set up a remote debug session using a modem

For additional information about null modem configuration, click the following article number to view the article in the Microsoft Knowledge Base:

151981 How to set up a remote debug session using a null modem cable

/crashdebug

This switch loads the kernel debugger when you start the operating system. The switch remains inactive until a Stop message error occurs. /crashdebug is useful if you experience random kernel errors. With this switch, you can use the COM port for normal operations while Windows is running. If Windows crashes, the switch converts the port to a debug port. (This action turns on remote debugging.)

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

151981 How to set up a remote debug session using a null modem cable

/debug

This switch turns on the kernel debugger when you start Windows. The switch can be activated at any time by a host debugger that is connected to the computer, if you want to turn on live remote debugging of a Windows system through the COM ports. Unlike the /crashdebug switch, /debug uses the COM port whether you are debugging or not. Use this switch when you are debugging problems that are regularly reproducible.

For additional information about remote debugging, click the following article number to view the article in the Microsoft Knowledge Base:

121543 Setting up for remote debugging

/debugport=comnumber

This switch specifies the communications port to use for the debug port, where number is the communications port, such as COM1, that you want to use. By default, /debugport uses COM2 if it exists. Otherwise, the switch uses COM1. If you include this switch in the Boot.ini file, the /debug switch becomes active.

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

151981 How to set up a remote debug session using a null modem cable

/maxmem=number

This switch specifies the maximum amount of RAM that Windows can use. Do not make this setting less than 12. Use this parameter to confirm whether a memory chip is faulty. For example, if you have a 128-megabyte (MB) system that is equipped with two 64-MB RAM modules, and you are experiencing memory-related Stop messages, you can type /maxmem=64. If the computer starts Windows and operates without problems, replace the first module to see if this action resolves the problem.

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

108393 MAXMEM option in Windows NT Boot.ini file

/noguiboot

This switch disables the bitmap that displays the progress bar for Windows startup. (The progress bar appears just before the logon prompt.)

/nodebug

This switch turns off debugging. This scenario can cause a Stop error if a program has a debug hardcoded breakpoint in its software.

/numproc=number

This switch sets the number of processors that Windows will run at startup. With this switch, you can force a multiprocessor system to use only the quantity of processors (number) that you specify. This switch can help you troubleshoot performance problems and defective CPUs.

/pcilock

For x86-based systems, this switch stops the operating system from dynamically assigning hardware input, hardware output, and interrupt request resources to Peripheral Connect Interface (PCI) devices. With this switch, the BIOS configures the devices.

/fastdetect:comnumber

This switch turns off serial and bus mouse detection in the Ntdetect.com file for the specified port. Use this switch if you have a component other than a mouse that is attached to a serial port during the startup process. For example, type /fastdetect:comnumber, where number is the number of the serial port. Ports may be separated with commas to turn off more than one port. If you use /fastdetect, and you do not specify a communications port, serial mouse detection is turned off on all communications ports.

Note In earlier versions of Windows, including Windows NT 4.0, this switch was named /noserialmice.

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

131976 How to disable detection of devices on serial ports

/sos

The /sos switch displays the device driver names while they are being loaded. By default, the Windows Loader screen only echoes progress dots. Use this switch with the /basevideo switch to determine the driver that is triggering a failure.

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

99743 Purpose of the Boot.ini file in Windows 2000 or Windows NT

/PAE

Use the /PAE switch with the corresponding entry in Boot.ini to permit a computer that supports physical address extension (PAE) mode to start normally. In Safe Mode, the computer starts by using normal kernels, even if the /PAE switch is specified.

/HAL=filename

With this switch, you can define the actual hardware abstraction layer (HAL) that is loaded at startup. For example, type /HAL=halmps.dll to load the Halmps.dll in the System32 folder. This switch is useful to try out a different HAL before you rename the file to Hal.dll. This switch is also useful when you want to try to switch between starting in multiprocessor mode and starting in single processor mode. To do this, use this switch with the /kernel switch.

/kernel=filename

With this switch, you can define the actual kernel that is loaded at startup. For example, type /kernel=ntkrnlmp.exe to load the Ntkrnlmp.exe file in the System32 folder. With this switch, you can switch between a debug-enabled kernel that is full of debugging code and a regular kernel.

/bootlog

This switch turns on boot logging to a file that is named systemroot\Ntbtlog.txt. For more information about boot logging, see Windows Help.

/burnmemory=number

This switch specifies the amount of memory, in megabytes, that Windows cannot use. Use this parameter to confirm a performance problem or other problems that are related to RAM depletion. For example, type /burnmemory=128 to reduce the physical memory that is available to Windows by 128 MB.

/3GB

This switch forces x86-based systems to allocate 3 GB of virtual address space to programs and 1 GB to the kernel and to executive components. A program must be designed to take advantage of the additional memory address space. With this switch, user mode programs can access 3 GB of memory instead of the usual 2 GB that Windows allocates to user mode programs. The switch moves the starting point of kernel memory to 3 GB. Some configurations of Microsoft Exchange Server 2003 and Microsoft Windows Server 2003 may require this switch.

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

823440 You must use the /3GB switch when you install Exchange Server 2003 on a Windows Server 2003-based system

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

171793 Information on application use of 4GT RAM tuning

/safeboot:parameter

This switch causes Windows to start in Safe Mode. This switch uses the following parameters:
  • minimal
  • network
  • safeboot:minimal(alternateshell)
You can combine other Boot.ini parameters with /safeboot:parameter. The following examples illustrate the parameters that are in effect when you select a Safe Mode option from the startup recovery menu.
  • Safe Mode with Networking
    /safeboot:minimal /sos /bootlog /noguiboot
  • Safe Mode with Networking
    /safeboot:network /sos /bootlog /noguiboot
  • Safe Mode with Command Prompt
    /safeboot:minimal(alternateshell) /sos /bootlog /noguiboot
Note The /sos, /bootlog, and /noguiboot switches are not required with any one of these settings, but the switches can help with troubleshooting. These switches are included if you press F8 and then select one of the modes.

/userva

Use this switch to customize the amount of memory that is allocated to processes when you use the /3GB switch. This switch permits more page table entry (PTE) kernel memory but still maintains almost 3 GB of process memory space.

For additional information about how to use the /USERVA switch, click the following article number to view the article in the Microsoft Knowledge Base:

316739 How to use the /USERVA switch in the Boot.ini file to tune /3GB configurations

For additional information, click the following article numbers to view the articles in the Microsoft Knowledge Base:

810371 XADM: Using the /userva switch on Windows Server 2003-based Exchange Servers

323427 HOW TO: Manually edit the Boot.ini file in a Windows Server 2003 environment

317526 HOW TO: Edit the Boot.ini file in Windows Server 2003

317521 Description of the Bootcfg command and its uses

289022 HOW TO: Edit the Boot.ini file in Windows XP

291980 A discussion about the Bootcfg command and its uses

/redirect

Use this switch to turn on Emergency Management Services (EMS) on a Windows Server 2003, Enterprise Edition-based computer. For additional information about EMS, search on "Emergency Management Services" in Windows Help and Support.

To turn on EMS by editing the Boot.ini on an x86-based computer, edit both the [boot loader] section and the [operating systems] section of the Boot.ini file. To do this, configure the following entries:
  • Under [boot loader], add one of the following required statements:
    redirect=COMx
    In this statement, replace x with one of the following COM port numbers:

    1
    2
    3
    4

    redirect=USEBIOSSETTINGS
    This statement permits the computer BIOS to determine the COM port to use for EMS.
  • Under [boot loader], add the following option statement:
    redirectbaudrate=baudrate
    Replace baudrate with one of the following values:

    9600
    19200
    57600
    115200

    By default, EMS uses the 9600 Kbps baud rate setting.
  • Under [operating systems], add the /redirect option to the operating system entry that you want to configure to use EMS. The following example illustrates the use of these switches:
    [boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
redirect=COM1
redirectbaudrate=19200
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Windows Server 2003, Enterprise" /fastdetect
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Windows Server 2003, EMS" /fastdetect /redirect

/channel

Use this switch together with the /debug switch and the /debugport switch to configure Windows to send debug information over an Institute of Electrical and Electronics Engineers, Inc. (IEEE) 1394 port. To support debugging over a 1394 port, both computers must be running Microsoft Windows XP or later. The 1394 port has a maximum number of 63 independent communications channels that are numbered 0 through 62. Different hardware implementations support a different number of channels across one bus. Windows XP has a limit of four destination computers. However, this limitation is removed in Windows Server 2003. To perform debugging, select a common channel number to use on both the computer that the debugger runs on, which is also known as the host computer, and the computer that you want to debug, which is also known as the destination computer. You can use any number from 1 to 62.

To configure the destination computer

  1. Edit the Boot.ini file to add the /CHANNEL=x option to the operating system entry that you have configured for debugging. Replace x with the channel number that you want to use. For example, configure the [operating systems] area of the Boot.ini file to look similar to the following:
    [boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Windows Server 2003, Enterprise" /fastdetect /debug /debugport=1394 /CHANNEL=3
  2. Plug the 1394 cable in one of the 1394 ports.
  3. Disable the 1394 host controller on the destination computer. To do this, start Device Manager, right-click the device, and then click Disable.
  4. Restart the computer.

To configure the host computer

  1. Plug the 1394 cable in one of the 1394 ports.
  2. Install the kernel debugger binary files.
  3. Start a command prompt. Press enter after you type each of the following commands:

    set_NT_DEBUG_BUS=1394
    set_NT_DEBUG_1394_CHANNEL=x
    kd -k

  4. Move to the folder where you installed the kernel debugger, and then type the following command:

    kd.exe

When you first start the debugger, a 1394 virtual driver is installed. This driver permits the debugger to communicate with the destination computer. You must be logged on with administrator rights for this driver installation to complete successfully.


diskmgmt.msc

Местонахождение

Windows\system32

Управление дисками - Disk Management

Оснастка Управление дисками предназначена для таких задач, как создание и форматирование разделов и томов и назначение букв дисков

Смотри также

Переназначить буквы дисков


lusrmgr.msc

Местонахождение

Windows\system32

Локальные пользователи и группы - Local Users and Groups

Оснастка Локальные пользователи и группы — это инструмент, предназначенный для управления локальными пользователями и группами.


oeminfo.ini

Местонахождение

Windows\system32

Описание

Если создать текстовый файл oeminfo.ini и поместить его в системную папку Windows (как правило Windows\system32), то в апплете Система Панели управления, появится кнопка Сведения о поддержке

Файл oeminfo.ini имеет следующую структуру:

[General]
Manufacturer=Название компании
Model=Название модели

[Support Information]
Line1=За поддержкой обращайтесь по телефону 03
Line2=Бла-бла-бла
Line3=Часы работы:
Line4=Понедельник-Пятница 08.00-16.00
Line5=Суббота-Воскресенье 11.00-12.00!
Line6=Всего шесть строчек

Строго говоря, данный файл не присутствует на чистом инсталяционном диске Windows, но может входить в Windows, который предустановлен на компьютерах различных производителей, имеющих соответствующую лицензию.

Смотри также файл oemlogo.bmp


oemlogo.bmp

Местонахождение

Windows\system32

Описание

Чтобы добавить собственную картинку в апплет Система Панели управления, надо создать или модифицировать картинку, которая находится в файле oemlogo.bmp и поместить файл в системную папку Windows (как правило Windows\system32)

Файл oemlogo.bmp создается в любом графическом редакторе (напр. Paint) с размером 172 на 100 пикселов (русская версия Windows XP). Надо сказать, что размеры картинки в разных версиях Windows постоянно менялись. Как правило, слишком большая картинка просто обрезается. Также необходимо иметь в этой же папке файл oeminfo.ini, иначе картинка не будет выводиться вообще

Строго говоря, данный файл не присутствует на чистом инсталяционном диске Windows, но может входить в Windows, который предустановлен на компьютерах различных производителей, имеющих соответствующую лицензию.


Службы в Windows

Ускорить работу системы, попутно освободив немного памяти, можно запретив загрузку ненужных системных служб. Отключить ненужные службы можно через оснастку Службы (Services). Здесь надо быть предельно осторожным, потому как последствия необдуманных действий могут быть непредсказуемы. Многие службы для своей работы требуют работы других служб, поэтому если Вы отключите слишком много лишнего, то можете столкнуться с такой ситуацией, что не сможете включить всё обратно. Какая служба от какой зависит можно посмотреть через закладку Dependencies из свойства службы. Но чтобы полностью избежать проблем при экспериментах со службами, мы бы советовали вам перед тем как производить эксперименты с службами сохранить ветку реестра отвечающую за запуск системных служб. Для этого в реестре найдите раздел HKLM\SYSTEM\CurrentControlSet\Serviсes. Ниже мы приведём несколько служб, которые могут быть отключены. Используйте эти советы на свой страх и риск, авторы не несут никакой ответственности за возможные последствия (список служб дан для XP Pro).

  • Print Spooler: Спулер печати, ускоряет печать; если принтера нет, то его можно отключить.
  • Automatic Updates: Автоматичесткое обновление. Если у вас нет постоянного соединения с Интернетом, или если вы просто хотите контролировать всё что делает компьютер, то обновлять программное обеспечение входящее в состав XP можно и вручную. Выключая эту службу не забудьте выключить Automatic Updates в одноименной закладке System Properties.
  • Cryptographic Service: Отвечает за безопасный обмен ключами и шифрование. Используется для установки защищённых соединений, как в локальной сети, так и в интернет, играет важную роль в поддержке шифрования файловой системой. Если вам не надо шифровать файлы находящиеся на NTFS разделах, и вы не планируете использовать защищённые соединения в интернет (что использует, например, Windows Update), можете эту службу отключить. Используется она и во время проверки системных файлов (команда sfc), поэтому перед такой проверкой не забудьте включть её обратно.
  • Portable media serial number: Обеспечивает получение серийного номера переносного музыкального устройства подключаемого к компьютеру. Очередное нововведение Microsoft в рамках борьбы с музыкальным пиратством. На сегодняшний день для большинства из нас эта служба не актуальна.
  • SSDP Discovery service: обеспечивает автоматических устройств подключаемых к сети устройств, поддерживающих UPnP. Пока что это редкость.
  • Terminal Service: Раньше эта служба была доступна только в серверных вариантах ОС. Она позволяет подключаться к Вашей машине про сети, и удалёно работать на ней. В XP Pro эта служба предназначена для удаленного администрирования Вашей машины, чтобы IT специалисту не приходилось бегать самому чинить всё что Вы там натворили, а можно было сделать это удалённо. Кроме этого, через эту службу работает переключение пользователей на одной машине (Switch User). Если Вам эти возможности не нужны, можете отключить эту службу.
  • Windows time: синхронизирует время на локальной машине и сервере. Нет time-сервера - служба не нужна.
  • Messenger: Принимает и отправляет сообщения, посланные администратором. Если нет сети и администратора, то можно отключить.
  • Protected Storage: Служит для защиты важных данных, ключей пользователей. Запрещает неавторизированный доступ. Если нет сети (в том числе Интернет), или безопасность не волнует, то данный сервис можно отключить.
  • Computer Browser: Обновляет список компьютеров в сети. Если у вас нет локальной сети, то можно отключить.
  • Server: Обеспечивает общий доступ к принтерам, папкам и файлам, а также обеспечивает поддержку Remote Procedure Call. В случае, если у вас нет ни сетевой карты, ни модема, он вам не нужен.
  • Network Connections: Занимается управлением объектами в директории Network and Dial-Up Connections, то есть всеми сетевыми соединениями. Если нет сети, то он становится не нужным.
  • DHCP client: Отвечает за автоматическое распределение IP-адресов. Если нет сети (ни локальной, ни модема), то он не нужен.
  • Telephony: Работает с модемом. Если модема нет, то он не нужен.
  • Telnet: Обеспечивает возможность соединения и удалённой работы с хостами по протоколу telnet. Если уверены, что это не пригодится, то данный сервис можно отключить.

Этот список можно ещё продолжить, необходимость того или иного сервиса определяется задачами, которые выполняются на конкретной машине, и установленным аппаратным обеспечением. Поэтому каждый должен сам решать, что можно отключить.